Sign in to follow this  
Mykas0

"Error connecting to Server. Please retry updating at another time."

Recommended Posts

I erased "settings.awc" and "stats.awd", reinstalled the whole program AND I am still having my issue, both the update AND the freezing one.

 

Got rid of the entire proxy thing, and now I generated a new log:

 

Logfile of HijackThis v1.99.1

Scan saved at 1:29:51, on 24-07-2006

Platform: Windows XP SP2 (WinNT 5.01.2600)

MSIE: Internet Explorer v6.00 SP2 (6.00.2900.2180)

 

Running processes:

C:\WINDOWS\System32\smss.exe

C:\WINDOWS\system32\winlogon.exe

C:\WINDOWS\system32\services.exe

C:\WINDOWS\system32\lsass.exe

C:\WINDOWS\system32\Ati2evxx.exe

C:\WINDOWS\system32\svchost.exe

C:\WINDOWS\System32\svchost.exe

C:\WINDOWS\system32\spoolsv.exe

C:\Programas\Avast4\aswUpdSv.exe

C:\Programas\Avast4\ashServ.exe

C:\WINDOWS\system32\cisvc.exe

C:\WINDOWS\system32\svchost.exe

C:\Programas\VMware Workstation\vmware-authd.exe

C:\Programas\Ficheiros comuns\VMware\VMware Virtual Image Editing\vmount2.exe

C:\WINDOWS\system32\vmnat.exe

C:\WINDOWS\SYSTEM32\ZONELABS\vsmon.exe

C:\WINDOWS\system32\vmnetdhcp.exe

C:\Programas\Avast4\ashMaiSv.exe

C:\Programas\Avast4\ashWebSv.exe

C:\WINDOWS\System32\svchost.exe

C:\WINDOWS\system32\Ati2evxx.exe

C:\WINDOWS\Explorer.EXE

C:\PROGRA~1\DAP\DAP.EXE

C:\WINDOWS\ALCXMNTR.EXE

C:\Programas\Adobe\Acrobat 7.0\Distillr\Acrotray.exe

C:\PROGRA~1\Avast4\ashDisp.exe

C:\Programas\Gmail Notifier\gnotify.exe

C:\Programas\Ficheiros comuns\soft602\pdfSaver.exe

C:\Programas\Java\jre1.5.0_06\bin\jusched.exe

C:\Programas\ZoneAlarm\zlclient.exe

C:\WINDOWS\system32\ctfmon.exe

C:\Programas\Netcount\Netcount.exe

C:\Programas\3M PSNLite\PsnLite.exe

C:\PROGRA~1\3MPSNL~1\PSNGive.exe

C:\WINDOWS\system32\cidaemon.exe

C:\Programas\xchat\xchat.exe

C:\Programas\ICQLite\ICQLite.exe

C:\WINDOWS\system32\msiexec.exe

C:\Programas\Internet Explorer\iexplore.exe

C:\Programas\MSN Messenger\msnmsgr.exe

C:\Programas\Hijack This\HJT.exe

 

R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = about:blank

R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName = Hiperligações

F2 - REG:system.ini: UserInit=C:\WINDOWS\system32\Userinit.exe

O1 - Hosts: 64.91.255.87 www.dcsresearch.com

O3 - Toolbar: DAP Bar - {62999427-33FC-4baf-9C9C-BCE6BD127F08} - C:\Programas\DAP\DAPIEBar.dll

O3 - Toolbar: Adobe PDF - {47833539-D0C5-4125-9FA8-0819E2EAAC93} - C:\Programas\Adobe\Acrobat 7.0\Acrobat\AcroIEFavClient.dll

O3 - Toolbar: &Google - {2318C2B1-4965-11d4-9B18-009027A5CD4F} - C:\WINDOWS\Downloaded Program Files\googlenav.dll

O4 - HKLM\..\Run: [DownloadAccelerator] C:\PROGRA~1\DAP\DAP.EXE /STARTUP

O4 - HKLM\..\Run: [AlcxMonitor] ALCXMNTR.EXE

O4 - HKLM\..\Run: [Acrobat Assistant 7.0] "C:\Programas\Adobe\Acrobat 7.0\Distillr\Acrotray.exe"

O4 - HKLM\..\Run: [iMJPMIG8.1] "C:\WINDOWS\IME\imjp8_1\IMJPMIG.EXE" /Spoil /RemAdvDef /Migration32

O4 - HKLM\..\Run: [MSPY2002] C:\WINDOWS\system32\IME\PINTLGNT\ImScInst.exe /SYNC

O4 - HKLM\..\Run: [PHIME2002ASync] C:\WINDOWS\system32\IME\TINTLGNT\TINTSETP.EXE /SYNC

O4 - HKLM\..\Run: [PHIME2002A] C:\WINDOWS\system32\IME\TINTLGNT\TINTSETP.EXE /IMEName

O4 - HKLM\..\Run: [avast!] C:\PROGRA~1\Avast4\ashDisp.exe

O4 - HKLM\..\Run: [{0228e555-4f9c-4e35-a3ec-b109a192b4c2}] C:\Programas\Gmail Notifier\gnotify.exe

O4 - HKLM\..\Run: [NeroFilterCheck] C:\WINDOWS\system32\NeroCheck.exe

O4 - HKLM\..\Run: [602PC SUITE PDF Saver] "C:\Programas\Ficheiros comuns\soft602\pdfSaver.exe"

O4 - HKLM\..\Run: [AdslTaskBar] rundll32.exe stmctrl.dll,TaskBar

O4 - HKLM\..\Run: [sunJavaUpdateSched] C:\Programas\Java\jre1.5.0_06\bin\jusched.exe

O4 - HKLM\..\Run: [Zone Labs Client] C:\Programas\ZoneAlarm\zlclient.exe

O4 - HKCU\..\Run: [CTFMON.EXE] C:\WINDOWS\system32\ctfmon.exe

O4 - HKCU\..\Run: [MsnMsgr] "C:\Programas\MSN Messenger\MsnMsgr.Exe" /background

O4 - HKCU\..\Run: [Netcount] C:\Programas\Netcount\Netcount.exe 0

O4 - HKCU\..\RunOnce: [iCQ Lite] C:\Programas\ICQLite\ICQLite.exe -trayboot

O4 - Global Startup: Adobe Acrobat Speed Launcher.lnk = ?

O4 - Global Startup: Post-it® Software Notes Lite.lnk = C:\Programas\3M PSNLite\PsnLite.exe

O8 - Extra context menu item: &Download with &DAP - C:\PROGRA~1\DAP\dapextie.htm

O8 - Extra context menu item: &Google Search - res://C:\WINDOWS\Downloaded Program Files\googlenav.dll/cmsearch.html

O8 - Extra context menu item: Backward &Links - res://C:\WINDOWS\Downloaded Program Files\googlenav.dll/cmbacklinks.html

O8 - Extra context menu item: Cac&hed Snapshot of Page - res://C:\WINDOWS\Downloaded Program Files\googlenav.dll/cmcache.html

O8 - Extra context menu item: Convert link target to Adobe PDF - res://C:\Programas\Adobe\Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIECapture.html

O8 - Extra context menu item: Convert link target to existing PDF - res://C:\Programas\Adobe\Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIEAppend.html

O8 - Extra context menu item: Convert selected links to Adobe PDF - res://C:\Programas\Adobe\Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIECaptureSelLinks.html

O8 - Extra context menu item: Convert selected links to existing PDF - res://C:\Programas\Adobe\Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIEAppendSelLinks.html

O8 - Extra context menu item: Convert selection to Adobe PDF - res://C:\Programas\Adobe\Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIECapture.html

O8 - Extra context menu item: Convert selection to existing PDF - res://C:\Programas\Adobe\Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIEAppend.html

O8 - Extra context menu item: Convert to Adobe PDF - res://C:\Programas\Adobe\Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIECapture.html

O8 - Extra context menu item: Convert to existing PDF - res://C:\Programas\Adobe\Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIEAppend.html

O8 - Extra context menu item: Download &all with DAP - C:\PROGRA~1\DAP\dapextie2.htm

O8 - Extra context menu item: Si&milar Pages - res://C:\WINDOWS\Downloaded Program Files\googlenav.dll/cmsimilar.html

O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Programas\Java\jre1.5.0_06\bin\ssv.dll

O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Programas\Java\jre1.5.0_06\bin\ssv.dll

O16 - DPF: {00B71CFB-6864-4346-A978-C0A14556272C} (Checkers Class) - http://messenger.zone.msn.com/binary/msgrchkr.cab31267.cab

O16 - DPF: {0EB0E74A-2A76-4AB3-A7FB-9BD8C29F7F75} (CKAVWebScan Object) - http://www.kaspersky.com/kos/eng/partner/d...can_unicode.cab

O16 - DPF: {14B87622-7E19-4EA8-93B3-97215F77A6BC} (MessengerStatsClient Class) - http://messenger.zone.msn.com/binary/Messe...nt.cab31267.cab

O16 - DPF: {2917297F-F02B-4B9D-81DF-494B6333150B} (Minesweeper Flags Class) - http://messenger.zone.msn.com/binary/MineS...er.cab31267.cab

O16 - DPF: {2A0DED63-24F3-4FD6-BEC4-58F8E1F0C205} (FileSharingCtrl Class) - http://appdirectory.messenger.msn.com/AppD...sharingctrl.cab

O16 - DPF: {6CB5E471-C305-11D3-99A8-000086395495} (Google Activate) - http://toolbar.google.com/data/pt-PT/big/1...g/GoogleNav.cab

O16 - DPF: {8E0D4DE5-3180-4024-A327-4DFAD1796A8D} (MessengerStatsClient Class) - http://messenger.zone.msn.com/binary/Messe...nt.cab31267.cab

O16 - DPF: {AB86CE53-AC9F-449F-9399-D8ABCA09EC09} (Get_ActiveX Control) - https://h17000.www1.hp.com/ewfrf-JAVA/Secur...loadManager.ocx

O16 - DPF: {B8BE5E93-A60C-4D26-A2DC-220313175592} (ZoneIntro Class) - http://messenger.zone.msn.com/binary/ZIntro.cab32846.cab

O16 - DPF: {F58E1CEF-A068-4C15-BA5E-587CAF3EE8C6} (MSN Chat Control 4.5) - http://chat.msn.com/bin/msnchat45.cab

O16 - DPF: {F6BF0D00-0B2A-4A75-BF7B-F385591623AF} (Solitaire Showdown Class) - http://messenger.zone.msn.com/binary/Solit...wn.cab31267.cab

O17 - HKLM\System\CCS\Services\Tcpip\..\{28CAFF9E-11C6-45A8-AF8B-E6342ECDE791}: NameServer = 194.65.100.117

O17 - HKLM\System\CS1\Services\Tcpip\..\{28CAFF9E-11C6-45A8-AF8B-E6342ECDE791}: NameServer = 194.65.100.117

O18 - Protocol: msnim - {828030A1-22C1-4009-854F-8E305202313F} - "C:\PROGRA~1\MSNMES~1\msgrapp.dll" (file missing)

O23 - Service: Adobe LM Service - Adobe Systems - C:\Programas\Ficheiros comuns\Adobe Systems Shared\Service\Adobelmsvc.exe

O23 - Service: avast! iAVS4 Control Service (aswUpdSv) - Unknown owner - C:\Programas\Avast4\aswUpdSv.exe

O23 - Service: Ati HotKey Poller - ATI Technologies Inc. - C:\WINDOWS\system32\Ati2evxx.exe

O23 - Service: ATI Smart - Unknown owner - C:\WINDOWS\SYSTEM32\ati2sgag.exe

O23 - Service: avast! Antivirus - Unknown owner - C:\Programas\Avast4\ashServ.exe

O23 - Service: avast! Mail Scanner - Unknown owner - C:\Programas\Avast4\ashMaiSv.exe" /service (file missing)

O23 - Service: avast! Web Scanner - Unknown owner - C:\Programas\Avast4\ashWebSv.exe" /service (file missing)

O23 - Service: InstallDriver Table Manager (IDriverT) - Macrovision Corporation - C:\Programas\Ficheiros comuns\InstallShield\Driver\11\Intel 32\IDriverT.exe

O23 - Service: Remote Packet Capture Protocol v.0 (experimental) (rpcapd) - Unknown owner - %ProgramFiles%\WinPcap\rpcapd.exe" -d -f "%ProgramFiles%\WinPcap\rpcapd.ini (file missing)

O23 - Service: VMware Authorization Service (VMAuthdService) - VMware, Inc. - C:\Programas\VMware Workstation\vmware-authd.exe

O23 - Service: VMware DHCP Service (VMnetDHCP) - VMware, Inc. - C:\WINDOWS\system32\vmnetdhcp.exe

O23 - Service: VMware Virtual Mount Manager Extended (vmount2) - VMware, Inc. - C:\Programas\Ficheiros comuns\VMware\VMware Virtual Image Editing\vmount2.exe

O23 - Service: VMware NAT Service - VMware, Inc. - C:\WINDOWS\system32\vmnat.exe

O23 - Service: TrueVector Internet Monitor (vsmon) - Zone Labs, LLC - C:\WINDOWS\SYSTEM32\ZONELABS\vsmon.exe

 

I hope someone can finally fix my problem by now...

Share this post


Link to post
Share on other sites

Here is my entire list of Ad-Aware freezing issues fixes. I hope one of these works! :D

 

One observation recently for the freezing is that certain security software all running at the same time can cause conflicts. A number of Adaware users who also are running the beta version of SpySweeper have reported that disabling SpySweeper during an Adaware scan has resolved that conflict.

 

To temporarily disable SpySweeper:

Right click the Spy sweeper icon in the notification area (right side) of the system tray and choose shut down.

 

Try scanning again with Adaware, it should be able to complete the scan.

 

To re-enable SpySweeper:

Start it again from Start > All programs > Webroot > Spy Sweeper

...............................

 

If that isn't it, try these various steps.

 

First, do a disk cleanup to clear the browser cache and other unnecessary files.

 

Go to Start > Run and type in the box: Cleanmgr

Wait while Windows scans your system for files to delete.

Make sure these 3 are checkmarked and press *ok* to delete them.

 

Temporary Files

Temporary Internet Files

Recycle Bin

 

If you are still having a problem, there can be a number of reasons for this issue. Please try these steps next to see if any resolve the problem.

 

From the Ad-Aware FAQ

 

Q: Ad-Aware freezes while performing a scan.

 

A: There are a number of possible reasons behind this problem. To correct:

 

* First, update to Build 1.06 and download the latest definition file if you have not done so.

* Second, it is highly recommended that you run a disk defragmentation on your computer, then a thorough “Check� or “Scan Disk� depending on your Windows version. Try scanning in safe mode.

* Third, start Ad-Aware scan from the Windows command line. Do as follows:

o Click "Start", then "Run". Next, type the text shown below (including the quotation marks and with the same spacing as shown) for your version of Ad-Aware SE:

"C:\Program Files\Lavasoft\Ad-Aware SE Professional\Ad-Aware.exe" /full +procnuke

"C:\Program Files\Lavasoft\Ad-Aware SE Plus\Ad-Aware.exe" /full +procnuke

"C:\Program Files\Lavasoft\Ad-Aware SE Personal\Ad-Aware.exe" +procnukep

o Click “OK�.

o Note: The path above (between the quotes) is the default location of Ad-Aware SE. If you installed your Ad-Aware to a different directory, adjust the path accordingly. For Ad-Aware SE Personal, when the GUI launches, click “Start�, then “Full System Scan�. Click “Next�, then “OK�.

o When the scan is complete, select “Next�. In the “Scanning Results� window, select the "Scan Summary" tab. Check the box next to each "target family" you wish to remove, then click “Next�, then OK�.

* If you still have problems, cancel before the scan reaches the point of stalling -- for example, after 20 objects are detected. Click “Cancel� on your log file. Remove any objects you want and rescan. Again, stop the scan before it reaches the point of stalling and remove any additional objects. Then try a full scan without stopping it. This should work for you now.

 

If still no joy, try these steps:

 

Ad-Aware Freezing Issue

http://www.lavasoftsupport.com/index.php?s...amp;hl=Freezing

 

...........................

Have you ruled out any virus or trojan infections? I would recommend an online scan at one of the following (do a full system scan). The reason for doing an online scan is that some infections will disable your Antivirus installed on your PC to hide it's presence.

 

If any infections are found, save the log from the scan and post it back here:

eTrust Antivirus Web Scanner

http://www3.ca.com/securityadvisor/virusinfo/scan.aspx

(if prompted, please *allow* Active X and the install of software - this is needed to scan your system)

It will take a while to download the updates needed, and then you'll be presented with a screen to scan your system.

 

Ewido free online scanner

http://www.ewido.net/en/onlinescan/

 

Trend Micro (PC-cillin) - Free on-line Scan

http://housecall.antivirus.com

 

Panda's Active Scan

http://www.pandasoftware.com/products/activescan.htm

................

 

Let us know how you make out on all of the above, or if any of those steps resolve the problem.

Share this post


Link to post
Share on other sites

Ok, I am trying those. Here are the results:

 

- I don't have Spysweeper installed (I have Spybot, but it is never on at the time of the scan);

 

- I fully cleaned my system using "Cleanmgr", removed all items that appeared in there. Then, I tried to scan again, same problem;

 

- In the "From the Ad-Aware FAQ" section, I have yet to try those. I'll be defraging during the night, and tomorrow I'll post the results here;

 

- As for the virus problem, I had already thought about it. Scanned with "Avast", no problem found. Scanned with Kaspersky's online scanner, it found 2 virus, which I removed. I just installed "eTrust Antivirus Web Scanner", scanned, and got no virus. Tried the ewido one, got a whole bunch of tracking cookies, and this:

 

Name: Adware.NewDotNet

Path: C:\Documents and Settings\Administrador\Definições locais\Temp\SHNT288.exe

Risk: Medium

 

 

 

...

Maybe I didn't explained myself right, but I'll try again. In the freezing issue (yeah, the "updating" one is sill occuring >_< ), it doesn't happen during the scan, but on the quarentining section, when it hits 100%.

 

semttulohd1.gif

 

In this image, you can see where it freezes. When it reaches this position, I can leave it like that and it will never continue, I've tried for at least 30 minutes, and it doesn't advance...

Share this post


Link to post
Share on other sites

Try this one:

 

* If you still have problems, cancel before the scan reaches the point of stalling -- for example, after 20 objects are detected. Click “Cancel� on your log file. Remove any objects you want and rescan. Again, stop the scan before it reaches the point of stalling and remove any additional objects. Then try a full scan without stopping it. This should work for you now.

 

Caution on NewDotNet. If this program is on your computer, removal should ONLY be done via the methods in this link:

http://www.newdotnet.com/removal.html

 

Removing NewDotNet via any other method may cause you to lose your ability to connect to the internet.

Share this post


Link to post
Share on other sites

Completed the fragmentation scan a couple hours ago, it didn't worked like that, either.

 

Now, about the new one, I cancelled after getting 12 tracking cookies AND the freezing issue still occurs, when I try to quarantine them. :(

 

 

As for NewDotNet, I removed it "normally" (I mean, I just used that scanner's option for removal) and my connection still works. Yey!

Share this post


Link to post
Share on other sites

Sorry for the delay, I wasn't at home these days.

 

Yes, I used that method for the CHKDISK, but I didn't try the rootkit revealer and the other program. Should I try those?

Share this post


Link to post
Share on other sites

I had already tried those solutions, as stated before.

 

With "RootkitRevealer", the scan never ends (I've idled, turned I.E. and

Messenger off, and made it scan), it seems to freeze while scanning HKLM\System\WPA\Signing-Hash-XKRMQ[something here].

 

Using the "BlackLight" one, nothing was found.

 

Next, I will try another time the ewido online scanner. Wish me luck! :)

Share this post


Link to post
Share on other sites

Hmmmm, RootkitRevealer also freezes.

 

This is a long shot, but it won't hurt anything to run it. If no problems are found it will tell you. If a correction needs to be made it will fix it.

 

Download FIXPATH2.ZIP.

http://internet.cybermesa.com/~bstewart/files/fixpath2.zip

 

Extract the files to a folder in C:\, like C:\FIXPATH2.

 

RUNNING THE PROGRAM:

 

* Open a command prompt window by going to start > run and copy and type: cmd

In the command prompt, type: cd C:\ and press Enter

 

So you should get C:\>

 

Then type: cd FIXPATH2 and press Enter

 

So you should get: C:\>fixpath2

 

Then type: FIXPATH.EXE and press Enter

* It will display some preliminary information, and ask if it should continue and check for errors. Click Yes.

* If it successfully updates the Path value in the registry, you will need to

reboot for the change to take effect. !! This is really important !!

Share this post


Link to post
Share on other sites

Ok, this is what I got:

 

C:\fixpath2>fixpath

FIXPATH 2.0 - © 2004 by Bill Stewart ([email protected])

 

The system path is stored in the Path value in the following registry key:

 

HKLM\System\CurrentControlSet\Control\Session Manager\Environment

 

The Path registry value must be of type REG_EXPAND_SZ and must contain, at a

minimum, the following directories:

 

%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\system32\Wbem

 

If either of these conditions are false, then the Path is not correct. This

program attempts to correct both of these problems, if found.

 

You must be logged on as a user with sufficient permissions to update the Path.

 

You may run this program without user interaction by specifying /Q on the

command line.

 

Check for errors and attempt to repair now? (Y/N) Y

 

The registry value type is correct (REG_EXPAND_SZ).

The minimum required directories were found in the Path.

 

C:\fixpath2>

 

I think everything went fine, and yes, I was logged in as Administrator. I rebooted, and Ad-aware still freezes at the end. Any more ideas?

 

 

 

 

 

 

Anyway, back to the original problem, I can't update yet and the program is unusable, due to the freezing bug when quarantining. Do you think I should try using an older version of Ad-aware, and wait till the next one (or a beta) is released?

Share this post


Link to post
Share on other sites

Yours was correct, so that's not it:

The registry value type is correct (REG_EXPAND_SZ).

The minimum required directories were found in the Path.

Share this post


Link to post
Share on other sites

Hum, yeah. :-\ Any more ideas, LS CalamityJane ?

 

 

And like I said before, back to the original problem, I can't update yet and the program is unusable, due to the freezing bug when quarantining. Do you think I should try using an older version of Ad-aware, and wait till the next one (or a beta) is released?

Share this post


Link to post
Share on other sites

It is something on your end, Mykas0 that is not allowing the download of updates. I noticed you are using a download accelerator. Or perhaps the VMware?

 

As for the freezing during quarantine issue, I've not found answer on your issue. Perhaps it is having a problem deleting that SpyNuker key. Is it still find that one? Could you copy those results back here and perhaps we could try deleting it manually.

Share this post


Link to post
Share on other sites

VMWare has been around for ages (I use it to run Linux and other system at the same time I'm running my Native Windows XP), and so is "Download Acelerator Plus", so I don't understand how that could be the problem, since I didn't even changed anything about it.

 

 

As for SpyNuker, where did we see that before? I don't remember, do you? :|

Share this post


Link to post
Share on other sites

I'm having the identical problem. I'm sure this is of no help to you, other than letting you know that you are not the only one, so at least it's not something obscure and specific to your computer.

 

I've been able to manually update the file and copy it in to the folder, but not do it automatically.

Share this post


Link to post
Share on other sites

I just wanted to report that both my problems are now fixed. However, I haven't got a clue on how they got fixed: yesterday, I simply got home, used Ad-aware, clicked the update button and IT WORKED. So, I did the usual scan and at the end it didn't freeze.

 

FIXED, no idea how, though... -_-

Share this post


Link to post
Share on other sites

I missed seeing your reply here! So glad to hear that you finally got it resolved :blink:

 

Since it seems you're all set now, I'll go ahead and move this topic to the "Resolved" section (read onlyl).

 

Should you have any further issues, please feel free to start a new topic :angry:

Share this post


Link to post
Share on other sites
Sign in to follow this