Sign in to follow this  
abhi

HELP!

Recommended Posts

I do not have access to many of the control panel. I removed a virus manually from system32 and now I keep getting errors saying C:\WINDOWS\system32\rundll32.exe application not found. Along with that all the programs besides internet explorer, asks what program to open the file with. Please help.

Share this post


Link to post
Share on other sites
I do not have access to many of the control panel. I removed a virus manually from system32 and now I keep getting errors saying C:\WINDOWS\system32\rundll32.exe application not found. Along with that all the programs besides internet explorer, asks what program to open the file with. Please help.

 

I'm having the exact same problem. I had just upgraded from Adaware2008 (free) to Adaware 2008 Pro. I uninstalled Adaware 2008 Free FIRST, before installing the Pro version. Everything went well. I did ALL the updates. Then rebooted.

 

Now I have the same situation you have: every program icon I click says there is no program associated. All my anti-virus, anti-trojan, even Adaware 2008 Pro is GONE. I had updated all my security protection programs BEFORE I downloaded and installed Adaware Pro 2008. All scans CLEAN. I've had NO PROBLEMS on this machine whatsoever until this reboot after installing and updating Adaware 2008 Pro.

 

Now my machine is effectively hosed. I can't use "System Retore" because I get the same message: no program associated with this icon.

 

I'm advised by XP to go to File Options and choose a program to associate. But the programs are just NOT THERE. Not when I look at the drives in Windows Explorer, either. They're just GONE.

 

What can be done to rememedy this extreme error. Reinstalling XP would be a pretty serious disaster, at this point, as this is a BUSINESS machine.

Share this post


Link to post
Share on other sites
I'm having the exact same problem. I had just upgraded from Adaware2008 (free) to Adaware 2008 Pro. I uninstalled Adaware 2008 Free FIRST, before installing the Pro version. Everything went well. I did ALL the updates. Then rebooted.

 

Now I have the same situation you have: every program icon I click says there is no program associated. All my anti-virus, anti-trojan, even Adaware 2008 Pro is GONE. I had updated all my security protection programs BEFORE I downloaded and installed Adaware Pro 2008. All scans CLEAN. I've had NO PROBLEMS on this machine whatsoever until this reboot after installing and updating Adaware 2008 Pro.

 

Now my machine is effectively hosed. I can't use "System Retore" because I get the same message: no program associated with this icon.

 

I'm advised by XP to go to File Options and choose a program to associate. But the programs are just NOT THERE. Not when I look at the drives in Windows Explorer, either. They're just GONE.

 

What can be done to rememedy this extreme error. Reinstalling XP would be a pretty serious disaster, at this point, as this is a BUSINESS machine.

 

Okay, my problem is not "exactly" like yours. Mine has nothing to do with removing any virus DLL from my system. But the results are the same as what you describe. Nothing works except IE. I did manage to get this version of Firefox (3.01) to work in a seldom-used account on my machine.

 

My system worked perfectly UNTIL I did this install of Adaware 2008 Pro. I just don't know what has been wiped out. I can't use System Restore. Doesn't work. I can't use anything in Control Panel. "No program associated with this icon." etc.

 

I did a SAFE-MODE reboot, but it's still the same problem, even in Safe mode.

 

I'm pretty desperate at this point because there is a lot of unbacked-up data on this business machine. (I delayed all this time upgrading to Adaware 2008 Pro because of all the problems I had when I was an early-adopter in Adaware 2007. I thought if I waited this long, Lavasoft would have all the bugs in 2008 worked out. Now I feel very foolish for having taken this plunge into Pro 2008. My machine is HOSED.)

Share this post


Link to post
Share on other sites
Okay, my problem is not "exactly" like yours. Mine has nothing to do with removing any virus DLL from my system. But the results are the same as what you describe. Nothing works except IE. I did manage to get this version of Firefox (3.01) to work in a seldom-used account on my machine.

 

My system worked perfectly UNTIL I did this install of Adaware 2008 Pro. I just don't know what has been wiped out. I can't use System Restore. Doesn't work. I can't use anything in Control Panel. "No program associated with this icon." etc.

 

I did a SAFE-MODE reboot, but it's still the same problem, even in Safe mode.

 

I'm pretty desperate at this point because there is a lot of unbacked-up data on this business machine. (I delayed all this time upgrading to Adaware 2008 Pro because of all the problems I had when I was an early-adopter in Adaware 2007. I thought if I waited this long, Lavasoft would have all the bugs in 2008 worked out. Now I feel very foolish for having taken this plunge into Pro 2008. My machine is HOSED.)

 

 

Well, for me, i have access to the stuff saved on here. I can get it through the hard disk onto a flash drive. But the problem is that i have no access to any microsoft programs. They simply don't work. The control pannel doesn't work. I cannot download anything that might be able to fix it and well that is pretty much it. I can use firefox and flock but i need to find the program through the program list first.

 

Also, when i start the computer up, many programs that used to run doesn't anymore. Like yahoo messenger. But the problem is that rundll isn't missing like it says. It is at the location it is supposed to be. So what is wrong, I don't know.

Share this post


Link to post
Share on other sites
Okay. I tried most of the things that was said on there. No result. I am now trying the service pack 2 to see if that will work. Will post back.

 

 

I downloaded it but i couldn't install it. It keeps freezing when i try to run it. So no result out of that. Also, i cannot download anything for some reason. I click run but it asks, what program to use.

Share this post


Link to post
Share on other sites

You have not been forgotten - I have asked for some extra help as this does not seem to be a AAW issue.

Share this post


Link to post
Share on other sites
Please try the following link. I hope you have the OS CD ROM.

 

http://support.microsoft.com/kb/812340/en-us

 

If not you can always borrow one from someone and copy the file 'rundll32.exe' off it to your PC.

 

Anything else? It will not work. It asked what program to use to run: expand X:\i386\rundll32.ex_ c:\windows\system32\rundll32.exe With X being D. I tried making it rundll32.ex_ but Another error comes up saying... C:\WINDOWS\system32\expand.exe is not a valid Win32 application.

 

I don't know.

 

Another question. What would happen if i was to reinstall Windows XP. Would all the files be lost?

Share this post


Link to post
Share on other sites

You would overwrite ALL your files and go back to a clean machine. My advice would be to take the machine to a PC repair place and ask them to fix it. They would be able to back up all your important files then install a clean O/S and restore your files and programs. It sounds to me you have a big problem that we are unable to fix on this forum.

 

Please post back either way. I will make a complete copy of this post and have another read through it in case I have missed something.

 

Before you do anything. Just been asked if you could post a HJT log for us please.

Edited by Pierre67
Extra info.

Share this post


Link to post
Share on other sites
You would overwrite ALL your files and go back to a clean machine. My advice would be to take the machine to a PC repair place and ask them to fix it. They would be able to back up all your important files then install a clean O/S and restore your files and programs. It sounds to me you have a big problem that we are unable to fix on this forum.

 

Please post back either way. I will make a complete copy of this post and have another read through it in case I have missed something.

 

Before you do anything. Just been asked if you could post a HJT log for us please.

 

SO just post on hijackthis log?

Share this post


Link to post
Share on other sites

I don't know. When i go to the control pannel and try to go somewhere like add or remove programs or user accounts, there is an error saying C:\WINDOWS\system32\rundll32 application not found. This started to happen after spools got into the system and when i deleted it manually, nothing worked besides internet. there might be another problem because everytime i try to run a something, it asks what program to use. So even with the OS cd and microsoft instruction to install rundll, it didn't work.

 

I don't know if it is one problem or two different but many things have not worked. Start/run doesn't work since it also asks for the program to use. Antispy doesn't work since i can't download much thing because of the programs thing.

 

Please help!

Share this post


Link to post
Share on other sites
You would overwrite ALL your files and go back to a clean machine. My advice would be to take the machine to a PC repair place and ask them to fix it. They would be able to back up all your important files then install a clean O/S and restore your files and programs. It sounds to me you have a big problem that we are unable to fix on this forum.

 

Please post back either way. I will make a complete copy of this post and have another read through it in case I have missed something.

 

Before you do anything. Just been asked if you could post a HJT log for us please.

 

I don't think that i could post the log. First of all, i cannot download anything so i couldn't run the porgram.

Share this post


Link to post
Share on other sites
Hi abhi ;)

Is NERO ( Burning software ) installed ?

You also can try this...

disable the auto start of these programs that recently installed.

Reboot.

Let us know what happens.

Cheerio

Raziel :unsure:

 

How would you disable the autostart?

Share this post


Link to post
Share on other sites
Hi abhi ;)

Is NERO ( Burning software ) installed ?

You also can try this...

disable the auto start of these programs that recently installed.

Reboot.

Let us know what happens.

Cheerio

Raziel :unsure:

 

Also, I do not thin that NERO is installed.

Share this post


Link to post
Share on other sites

IS there another way to get to that? OR tell me where it is located in C: or something. Run asks for what program to run msconfig with.

Share this post


Link to post
Share on other sites

Hi again :)

left-click Start/Run and type msconfig it's not rocket science.

 

post-28338-1217249966.jpg

 

you should see this in your language, now make your settings.

 

post-28338-1217249972.jpg

 

Got some news from Pierre that I have to check first, I'll post back tomorrow.

Cheerio

Raziel :)

Share this post


Link to post
Share on other sites
Hi again :)

left-click Start/Run and type msconfig it's not rocket science.

 

That's not what i meant. I know how to do it but once i click okay, the computer asks for what program to use to open the file. That is one of the problems i am trying to fix. But i got it now.

 

Just to make sure, which tab to click? The one on the right says startup not software or anything else.

Share this post


Link to post
Share on other sites
Hi :D

are you able to get eMails and can you open it ?

If so I'll try to send you a new DLL.

Pls have a look to this first and

follow the prompts.

Cheerio

Raziel ;)

 

I can get emails. I can look at it and i don't know if i can open attachment or anything like that. Also, how do you find the Xp product key?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this