Sign in to follow this  
Andy74

Re-Install SPMgr.exe application

Recommended Posts

i have deleted the MFC70U.DLL after adaware advised it was a trojan. restarted as adaware had suggested and now i get a message stating i have to re-install the SPMgr.exe application in order to fix the problem. However i have re-started my sony vaio a number of few times and the error keeps popping up. i was unable to retrieve the MFC70U.DLL from quarantine so i uninstalled adaware annaversary. have done a system restore but that hasn't worked. any suggestions on how i can fix this problem.

Share this post


Link to post
Share on other sites
First I need to see your Ad-Aware scan log to make sure we replace the file in all locations (there may have been more than one). And please make sure that you rebooted/restarted your machine after "cleaning". If you did not do that then, please do it now.

 

And here is a guide for you on how to find and post that log:

Guide for posting false positives

http://www.lavasoftsupport.com/index.php?showtopic=18033

 

And then one of us will guide you through restoring the file(s) deleted.

Share this post


Link to post
Share on other sites
i have deleted the MFC70U.DLL after adaware advised it was a trojan. restarted as adaware had suggested and now i get a message stating i have to re-install the SPMgr.exe application in order to fix the problem. However i have re-started my sony vaio a number of few times and the error keeps popping up. i was unable to retrieve the MFC70U.DLL from quarantine so i uninstalled adaware annaversary. have done a system restore but that hasn't worked. any suggestions on how i can fix this problem.

 

Hi Andy74!

 

SPMgr.exe, located in "%programfiles%\Sony\VAIO Power Management\", provides additional configuration options for Sony Vaio laptops. SPMgr.exe is probably loaded on system startup, see Registry key: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run". This makes the error pop up at each restart.

 

Reinstalling the "VAIO Power Management" from your Sony install cd may fix the issue and reinstall the deleted shared library file.

 

Here is some other info that might be helpful:

 

Sony also offers a utility that installs the originally shipped version of the Sony Shared Library for Microsoft Windows XP. Here is some info about that utility for the Sony Vaio VGNFE590 model,

ht tp://esupport.sony.com/US/perl/swu-download.pl?mdl=VGNFE590&upd_id=1846&os_id=7

The described utility is only applicable for certain Vaio models (running Microsoft Windows XP) and you would have to search for the correct utility that is suitable for your specific model. The originally shipped version of the Sony Shared Library for Microsoft Windows XP (for the Sony Vaio VGNFE590) is available for download at f tp://download.sony.com/US/pc/SOASSL-00598801-US.EXE

The applicable models and Operating Systems for this utility is shown at h ttp://esupport.sony.com/US/perl/swu-matrix.pl?upd_id=2148 (associated mainly to the Sony Vaio VGNFE590 model).

 

Regards,

 

LS Pekka

 

Lavasoft Malware Labs

Share this post


Link to post
Share on other sites
Sign in to follow this