Sign in to follow this  
Newfan

Update Question - update failure at threatwork

Recommended Posts

I currently have Ad-Aware Version 8.1.3 (Database Version 0149.0118) on my PC. Is this the most current version? If do a web update it seems a new version is being downloaded but I can never complete the update as halfway through I always receive a 'Connection Error, check your settings' error. What is the most current version of Ad-Aware?

Share this post


Link to post
Share on other sites
Hi Newfan, welcome to the [b]Lavasoft Support Forum[/b] :D


You currently have the latest software updates and database updates.

Are you behind a firewall or using a proxy?

Share this post


Link to post
Share on other sites
Running A-A 8.1.3 ver. 0149.0117, attempted to update. Repeatably, at (or very near) download completion of threatwork.exe....--which is about 90% of the way thru download package--I get a connection error: check settings flag (& disconnect from lavasoft), but there seems to be nothing wrong from me thru tmy ISP (=ATT Yahoo! via IE 8.0.6001). Please fix or advise. Thanks!

Share this post


Link to post
Share on other sites
[quote name='WDF1' post='114541' date='Dec 18 2009, 11:07 PM']Running A-A 8.1.3 ver. 0149.0117, attempted to update. Repeatably, at (or very near) download completion of threatwork.exe....--which is about 90% of the way thru download package--I get a connection error: check settings flag (& disconnect from lavasoft), but there seems to be nothing wrong from me thru tmy ISP (=ATT Yahoo! via IE 8.0.6001). Please fix or advise. Thanks![/quote]

Hi I've been getting this issue as well for about the last 6 hours. Upon downloading threatwork.exe it gets to the end or near it, then gives a Connection Error/Check settings msg
Seems like something is up with theupdate

Share this post


Link to post
Share on other sites
I think there's something glitchy about today's update - 8.1.3 was released yesterday, but today people reported that the update reverted back to 8.1.2: [url="http://www.lavasoftsupport.com/index.php?showtopic=28056"]http://www.lavasoftsupport.com/index.php?showtopic=28056[/url].

Also, another user reported the same update connection error, so I'm merging the 2 topics together.

I also had a problem with the manual download of definitions. It was supposed to be 149.118, but I got 149.115 this morning. This evening, the 149.118 downloaded properly.

Since Lavasoft is off for the weekend, I think we'll have to sit tight and see what happens on Monday, then we can report any problems. Edited by visitor

Share this post


Link to post
Share on other sites
[quote name='SpySentinel' post='114535' date='Dec 19 2009, 01:51 PM']Hi Newfan, welcome to the [b]Lavasoft Support Forum[/b] :D
You currently have the latest software updates and database updates.

Are you behind a firewall or using a proxy?[/quote]


If I have the latest software updates and database updates why is Ad-Aware downloading more updates. I am only using a firewall.

Share this post


Link to post
Share on other sites
I have reported this to Lavasoft.

Like visitor said, there may be a glitchy update to blame. We will wait until Monday to see what happens.

@Newfan, do you have your firewall set to allow LSUpdate.exe and the other Ad-Aware files?

Share this post


Link to post
Share on other sites
[quote name='SpySentinel' post='114550' date='Dec 19 2009, 03:49 PM']I have reported this to Lavasoft.

Like visitor said, there may be a glitchy update to blame. We will wait until Monday to see what happens.

@Newfan, do you have your firewall set to allow LSUpdate.exe and the other Ad-Aware files?[/quote]

Yes my firewall is set to allow LSUpdate.exe and the other Ad-Aware files. I have never had problem downloading Ad-Aware files before.

Share this post


Link to post
Share on other sites
[quote]Yes my firewall is set to allow LSUpdate.exe and the other Ad-Aware files. I have never had problem downloading Ad-Aware files before.[/quote]

Like I said, I have reported this issue.

Share this post


Link to post
Share on other sites
Hello Everyone,

Firstly, thank you lavasoft for ad-aware. I have been using it for years!

New Fan, I had the same problem. I successfully updated it on my desktop, but my laptop stops updating at the threatwork.exe file shown below.

[attachment=7604:error.JPG]


If there is a solution...I guess all we can do is wait.

JC

Share this post


Link to post
Share on other sites
I got that error as well, i uninstalled Ad-aware and reinstalled and now it doesn't even get started and i get that message.

Share this post


Link to post
Share on other sites
Just installed Adaware 8.1 on Windows 7 and the update function gives the error "Connection Error, check your settings". I tried the Workaround 1 from Casey_boy's May 6 post. Did not help. Don't have Vista so Workaround 2 does not apply. Don't have Terminal Services so Workaround 3 does not apply.

Any help would be appreciated.

Share this post


Link to post
Share on other sites
OS: Windows XP Home Edition SP2
AAW Ver.:8.1.3
Firewall: Windows Default

Tried updating from Start Menu, no luck.
Tried Workaround 1, but option was already selected.
Tried Workaround 3, changed startup type for Terminal Services from Manual to Automatic, reboot and then tried update again, no luck

Share this post


Link to post
Share on other sites
Same connection issue during an update with current version. Was working quite well prior to a couple days ago. Tried the pinned workarounds suggesting adjusting the services to compatible with XP SP2 or failing success, adjusting to 98 SE. Neither works for my Vista Home Premium 64 bit OS. Will just uninstall and leave the app off my box until someone finds a definitive cause and solution.

Jester

Share this post


Link to post
Share on other sites
[quote name='deanzoodad' post='114557' date='Dec 19 2009, 09:28 AM']Just installed Adaware 8.1 on Windows 7 and the update function gives the error "Connection Error, check your settings". I tried the Workaround 1 from Casey_boy's May 6 post. Did not help. Don't have Vista so Workaround 2 does not apply. Don't have Terminal Services so Workaround 3 does not apply.

Any help would be appreciated.[/quote]

Run ad-aware as administrator and disable your anti-virus, when i did this, it solves my problem :)

Share this post


Link to post
Share on other sites
[quote name='nexico' post='114563' date='Dec 19 2009, 08:50 AM']Run ad-aware as administrator and disable your anti-virus, when i did this, it solves my problem :)[/quote]
Tried that, same error.

Share this post


Link to post
Share on other sites
just thought I would inform you that Ad-aware finally updated successfully, maybe the Network was on high demand yesterday causing it to Error out but i don't know, its all good now though

Share this post


Link to post
Share on other sites
Thanks for letting us know :)

I will update everyone and let you all know if it was indeed a high network demand on the database server.

Share this post


Link to post
Share on other sites
[b]*Update*[/b]

There has been an official response from Lavasoft that I posted here:
[url="http://www.lavasoftsupport.com/index.php?showtopic=28071"]http://www.lavasoftsupport.com/index.php?showtopic=28071[/url]

Share this post


Link to post
Share on other sites
[quote name='SpySentinel' post='114572' date='Dec 19 2009, 03:39 PM']Thanks for letting us know :)

I will update everyone and let you all know if it was indeed a high network demand on the database server.[/quote]

I agree that the update process works as of this writing--but used a smaller set of files, transmitted more quickly, than the problem update. I did not see threatwork.exe...., but it may have been there (filenames went flying past very quickly). Anyway, I'm grateful (but to whom?).

Share this post


Link to post
Share on other sites
Sign in to follow this