• Announcements

    • LS.Andy

      Support for other products than adaware, ad block, web protection and Web Companion   05/05/2017

      Support for the following products is handled by the Lavasoft support team: Lavasoft Tuneup Kit Lavasoft PC Optimizer Lavasoft Driver Updater Lavasoft Registry Tuner Lavasoft Privacy Toolbox Lavasoft File Shredder Lavasoft Digital Lock

      For help with these products, contact the support team here: http://www.lavasoft.com/support/supportcenter/
       
Sign in to follow this  
Followers 0
brusoft

No auto updates but manual works fine

13 posts in this topic

When I installed 8.1 I was having problems and traced it to when auto updates would occur.

[url="http://www.lavasoftsupport.com/index.php?showtopic=28445"]http://www.lavasoftsupport.com/index.php?showtopic=28445[/url]

I think the problem was similar to this:

[url="http://www.lavasoftsupport.com/index.php?showtopic=28235"]http://www.lavasoftsupport.com/index.php?showtopic=28235[/url]

Now after moving to 8.2 it does not auto update. I can manually update just fine and it seems to reinitialize fine so the initial problem appears to be resolved. I just can't get it to auto update (and yes I know it now only updates twice a week). Update settings are correct. Any thoughts?

Share this post


Link to post
Share on other sites
I'm still waiting for them to fix this issue since last fall. I even figured out exactly where the problem is and have reported this key bit of info but i don't think it got to lavasoft programmers. Those who don't have to keep their computers running all the time or for days at a time will not see this problem.

The thing i noticed is that when I reboot my computer Ad-Aware starts up with the AAWTray.exe running under the user. When it is loaded under the user it does successfully update but after the update AAWTray is running at system level instead of user level. When the AAWTray is running at system level update fails as i reported in previous posts. Then i have to help it finish the update by starting ad-aware manually. And it will continue to fail until the next time this computer gets rebooted and then it only works the one time as stated.

cressy


Edit to add

I was just checking the log files and see that most if not all parts of ad-aware received updates yesterday. Later today i will see if they have finally fixed this problem. Edited by cressy

Share this post


Link to post
Share on other sites
[quote name='brusoft' post='118110' date='Mar 18 2010, 09:16 PM']Now after moving to 8.2 it does not auto update.[/quote]
Make sure you've updated to 8.2.1, which was released this morning, and reboot your system. The changelog didn't list much detail as to what was fixed, so we'll need to report to Lavasoft any remaining bugs. Also, take a look at the Update.log to see what happened at the date/time it was supposed to update.

Share this post


Link to post
Share on other sites
[quote name='visitor' post='118113' date='Mar 19 2010, 01:11 AM']Make sure you've updated to 8.2.1, which was released this morning, and reboot your system. The changelog didn't list much detail as to what was fixed, so we'll need to report to Lavasoft any remaining bugs. Also, take a look at the Update.log to see what happened at the date/time it was supposed to update.[/quote]

Currently running 8.2.1 How do I find Update.log?

Share this post


Link to post
Share on other sites
[quote name='brusoft' post='118158' date='Mar 19 2010, 06:57 PM']How do I find Update.log?[/quote]
XP
C:\Documents and Settings\All Users\Application Data\Lavasoft\Ad-Aware\Logs

Vista
C:\ProgramData\Lavasoft\Ad-Aware\Logs\

Share this post


Link to post
Share on other sites
[quote name='visitor' post='118165' date='Mar 19 2010, 10:45 PM']XP
C:\Documents and Settings\All Users\Application Data\Lavasoft\Ad-Aware\Logs[/quote]

AFAICT all entries are related to the manual updates. I don't think it tries to update and then fails. It just doesn't update until I do it manually. I will not do any manual updates this week and see if there are any entries and will report back.

Some other thoughts. In system manager I have two entries related to AAW. AAWTray.exe in user and AAWService.exe in system. So unlike cressy it does not auto update once and then revert to system where it then fails. Should there be anything in system manager related to update (AAWUpd.exe or similar)? What about in System Startup, should there be anything there?

As mentioned, this started with 8.1 (where I think I did have the problem as cressy describes it) but now in 8.2.1 it won't even try to auto update and then fail. There is a bug somewhere. It has a workaround (manual update) but I 'd rather it work as described.

Share this post


Link to post
Share on other sites
With 8.2 and 8.2.1 (free version) it only updates 2 times a week instead of 4 times a day 7 days a week. Check your scheduled tasks and make sure there is an entry for Ad-Aware update. Start-> Accessories->System Tools-> Scheduled tasks. While there make note of the time of day that it is supposed to update. If your computer is not on at the time that it says it skips that update and will not try again until the next scheduled time. That is not a very good way to have it in my opinion but nobody listens to use users now do they, lol. I created my own entry in task scheduler to make it check for updates every afternoon. Once a day is good enough as long as you set it for a time a few hours after definitions usually come out. That way there is some leeway if they are late as this can happen sometimes.

If there is no entry i can help you set one up if you ask.

cressy

Share this post


Link to post
Share on other sites
[quote name='cressy' post='118177' date='Mar 20 2010, 10:32 AM']Check your scheduled tasks and make sure there is an entry for Ad-Aware update. Start-> Accessories->System Tools-> Scheduled tasks. While there make note of the time of day that it is supposed to update. If your computer is not on at the time that it says it skips that update and will not try again until the next scheduled time.[/quote]

There is indeed an entry in Scheduled Tasks for Ad-Aware Update, it states: Name: Ad-Aware Update(weekly); Schedule: At 7:29 PM every Thu, Sun of every week, starting 3/4/2010; Next Run Time: 7:29:00 PM 3/21/2010; Last Run Time: Never

I am certain the computer has been on all or certainly most of the times it was scheduled to auto update. But as Scheduled Tasks states, it has never auto updated. So what now?

Share this post


Link to post
Share on other sites
Mine says never run also, I believe that is because every time update runs it recreates that entry. You can verify that it recreates the entry every time by making a change to when it is supposed to run and then check it after it has run and you will see that it has been changed back to what it was.

So thursday evening and sunday evening are the times yours is set to run auto update. Could you make a point of watching to see what it does or doesn't do sunday evenng.

Also if you attach aawadmin.log and update.log i can take a closer look at what it is doing at those times.

cressy

Share this post


Link to post
Share on other sites
[quote name='cressy' post='118185' date='Mar 20 2010, 07:28 PM']Also if you attach aawadmin.log and update.log i can take a closer look at what it is doing at those times.[/quote]

I already have the current definition file so I will have to wait until next scheduled auto update to see if it works.

update.log did report the following tonight:

[b]MSG [1584] 2010/03/21 19:29:07: Downloading file: metafile.dat size: 84kB
MSG [1584] 2010/03/21 19:29:08: Connected: download.lavasoft.com//public/aawamber/
MSG [3376] 2010/03/21 19:29:30: Update finished[/b]

No entry under aawadmin.log.

A user of Ad-Aware Pro posted how they were not getting auto updates so it appears this is not an isolated problem. To be continued...

Share this post


Link to post
Share on other sites
Well it looks like it is initiating the update process at the scheduled time. Since there was nothing to actually update it didn't need to reinitialize. Don't do a manual update today. Instead of waiting for thursday for it to try again you can change the scheduler by putting in a check mark next to monday. It will be changed back to what it was after ad-aware updates. Yours might be doing what my was doing with v8.1 and v8.2 where it gets the updated files but can't restart ad-aware to finish the process. v8.2.1 fixed this problem for me so i'm a little surprised that yours is still not cooperating because they made some very obvious (to me) changes to the way that it goes about restarting itself.

Share this post


Link to post
Share on other sites
[quote name='cressy' post='118229' date='Mar 22 2010, 10:32 AM']Instead of waiting for thursday for it to try again you can change the scheduler by putting in a check mark next to monday. It will be changed back to what it was after ad-aware updates.[/quote]

It worked! It did auto update when I changed the scheduler and importantly it reinitialized fine.

As you said it reverts back to the Thursday, Sunday auto updates, so hopefully it will do it again then. Not sure why it doesn't update daily. As casey boy pointed out over a month ago Lavasoft seems to imply it should [url="http://lavasoft.com/download_and_buy/produ...rison_chart.php"]http://lavasoft.com/download_and_buy/produ...rison_chart.php[/url] I'd like to see them fix that aspect. For now I'm happy it seems to be working. Thanks to everyone for the help.

Share this post


Link to post
Share on other sites
Good to see that it is working now. Since this issue is resolved I'll close this topic. If you need further assistance with this problem contact me and I'll reopen this topic. Glad we could help out.

cressy

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0