• Announcements

    • Andrew Browne

      Support for other products than adaware, ad block and Web Companion

      Support for the following products is handled by the Lavasoft support team: Lavasoft Tuneup Kit Lavasoft PC Optimizer Lavasoft Driver Updater Lavasoft Registry Tuner Lavasoft Privacy Toolbox Lavasoft File Shredder Lavasoft Digital Lock


      For help with these products, contact the support team here: http://www.lavasoft.com/support/supportcenter/

Sign in to follow this  
Followers 0
Ramled

Windows 7 does not recognise Ad-Aware 9 as anti-virus software

12 posts in this topic

I'm using the free version of Ad-Aware 9 and Windows 7 action center states that I have no anti-virus running. It offers to start awsc.exe, which I've tried several times but nothing happens. I see AAWservice.exe and AAWtray.exe running in task manager and when I launch Ad-Aware from the system tray it shows everything as OK. I'm just curious if this is just a Windows 7 bug I should ignore? I have Windows defender running as well but I've tried it with it turned off and it has no effect.
Thanks,
Ramled

Share this post


Link to post
Share on other sites
Hi Ramled,

Have you tried to uninstall and install Ad-Aware?
Uninstallation instruction: [url="http://www.lavasoftsupport.com/index.php?showtopic=30850"]http://www.lavasoftsupport.com/index.php?showtopic=30850[/url]

Share this post


Link to post
Share on other sites
Ramled, if you're going to ask the flippin question, look for an answer and respond....... Did your mommy not teach you this??? Edited by Russ7

Share this post


Link to post
Share on other sites
This is a support forum, please help each other with constructive suggestions and be nice.

Share this post


Link to post
Share on other sites
[quote name='Ramled' post='127229' date='Jun 4 2011, 10:51 PM']I'm using the free version of Ad-Aware 9 and Windows 7 action center states that I have no anti-virus running. It offers to start awsc.exe, which I've tried several times but nothing happens. I see AAWservice.exe and AAWtray.exe running in task manager and when I launch Ad-Aware from the system tray it shows everything as OK. I'm just curious if this is just a Windows 7 bug I should ignore? I have Windows defender running as well but I've tried it with it turned off and it has no effect.
Thanks,
Ramled[/quote]
Hi Ramled,

Lavasoft has released Ad-Aware version 9.0.7, which for example solves a problem with Security Center (Action Center) reporting that Ad-Aware is off, see [url="http://www.lavasoftsupport.com/index.php?showtopic=31393"]http://www.lavasoftsupport.com/index.php?showtopic=31393[/url]
Please, update to this new version. If it doesn't solve your issue, please return.

Share this post


Link to post
Share on other sites
Hi I've just downloaded ad aware 907 to be my antivirus and updated it. but I have the same symptoms as this topic
I'm using Vista 32 bit though and I'd prefer not to uninstall and reinstall as the file was over 100Mb to download..

Is there any other options to fix the awsc.exe not running and am I protected without it showing in the task manager? (aawtray.exe is listed)
The windows security centre doesn't report it started even after I ask it to.

cheers
Trev

Share this post


Link to post
Share on other sites
[quote name='trevbol' post='128490' date='Jul 28 2011, 10:24 AM']Hi I've just downloaded ad aware 907 to be my antivirus and updated it. but I have the same symptoms as this topic
I'm using Vista 32 bit though and I'd prefer not to uninstall and reinstall as the file was over 100Mb to download..

Is there any other options to fix the awsc.exe not running and am I protected without it showing in the task manager? (aawtray.exe is listed)
The windows security centre doesn't report it started even after I ask it to.

cheers
Trev[/quote]

Quick update here

It stopped working altogether for no reason and without telling me. (or me noticeing for ? how long)
I started it again and it wasn't detected again so I stopped the lavasoft service and started it again and it was detected (by windows security center) I checked the processes and only aawtray is listed. The lavasoft service is running too but no awsc.exe to be seen anywhere
The consol tells me everything is OK

can anyone tell me if I'm protected?

cheers

Share this post


Link to post
Share on other sites
Hi trevbol,

Do you see AAWService.exe in Task Manager after you have selected to show processes for all users?
That file is the Ad-Aware Service and should always be running, but not awsc.exe.

Do you have another antivirus program installed that may interfere with Ad-Aware?

Share this post


Link to post
Share on other sites
Hi Ceciliab

Yes I do have the AAWService.exe running (didn't think to look under all users!)
It's the windows service centre that says it's starting the awsc.exe file

and no I don't have any other antivirus..

Share this post


Link to post
Share on other sites
Hi trevbol,

awsc.exe is responsible for informing Security Center that Ad-Aware is running and it will only be running for a short time (usually at startup). Ad-Aware will work as usual even when awsc.exe can't run and the only issue is that you get the message from Security Center.

Share this post


Link to post
Share on other sites
Hi CeciliaB,

So I'm protected and the awsc exe doesn't work? I tried to run it from the prog files and it still makes no difference.. should I put it in the 'start up' folder or just tell the security centre to ignore aaw's status? funny how stopping the lavasoft service and starting it again works..

thanks

Share this post


Link to post
Share on other sites
Hi trevbol,

You are protected when you see the normal Ad-Aware icon next to the clock. If you want, you can turn off the warning in Security Center.

awsc.exe itself works since it can inform Security Center when you turn on the Ad-Aware service in Administration Tool - Services. When you do that the service will call awsc.exe. It is unknown at the moment why awsc.exe and Security Center cannot cooperate when Windows is started in some computers.

You can try to find information about Ad-Aware issues in the Event Viewer, if you want to investigate it further.

See also [url="http://www.lavasoftsupport.com/index.php?showtopic=31150&st=0&gopid=128133&#entry128133"]http://www.lavasoftsupport.com/index.php?s...mp;#entry128133[/url]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0