• Announcements

    • Andrew Browne

      Support for other products than adaware, ad block and Web Companion

      Support for the following products is handled by the Lavasoft support team: Lavasoft Tuneup Kit Lavasoft PC Optimizer Lavasoft Driver Updater Lavasoft Registry Tuner Lavasoft Privacy Toolbox Lavasoft File Shredder Lavasoft Digital Lock


      For help with these products, contact the support team here: http://www.lavasoft.com/support/supportcenter/

Sign in to follow this  
Followers 0
aatex

High CPU and RAM usage by AAWService.exe

20 posts in this topic

I have an ASUS 1005PE Netbook (1.6GHz Intel Atom N450 processor, 2Gb RAM) with a fresh install of Windows 7 w/ SP1 and all updates installed.

I installed Ad-Aware Pro 9.0 and then installed all updates so I now have Ad-Aware Pro 9.5.1.

CPU use regularly goes up to > 50% and RAM use regularly goes up to > 100Mb. When this happens, an svchost.exe process seems to accompany it, also using ~50% CPU and ~100Mb of RAM.

When this happens, it lasts for several minutes and renders the machine largely useless.

Is this normal? What is Ad-Aware doing when this happens?

Share this post


Link to post
Share on other sites
i have a similar problem with my asus gc5290, my cpu spikes to above 50% sometimes to 100% and ram to 75% the cpu temp also rises to about 65°C wile scanning
my computer specs are :[spoiler]Operating System
MS Windows 7 Home Premium 64-bit SP1
CPU
Intel Core i7 920 @ 2.67GHz
Bloomfield 45nm Technology
RAM
9.0GB Triple-Channel DDR3 @ 535MHz (8-8-8-20)
Motherboard
ASUSTeK Computer INC. CG5290 (LGA1366)
Graphics
VOJ320F1A ([email protected])
896MB GeForce GTX 260 (ASUStek Computer Inc)
Hard Drives
117GB INTEL SSDSA2M120G2GC ATA Device (SATA-SSD)
977GB Seagate ST31000528AS ATA Device (SATA)
Optical Drives
HL-DT-ST BDDVDRW GBC-H20L ATA Device
HL-DT-ST DVDRAM GH40N ATA Device
MagicISO Virtual DVD-ROM0000
Audio
SoundMAX Integrated Digital HD Audio[/spoiler]

Edit: seams my sister's laptop does the same thing during a scan. Edited by wootlink

Share this post


Link to post
Share on other sites
Me too! I have an older Dell Inspiron 2200 running XP. Since loading the latest update of AdAware, the laptop becomes virtually useless at times. When I run Task Manager, I invariably find that the cpu usage has spiked to 100% and STAYS THERE.
The only cure I've found is to use task manager to shut off AAW Service and everything else to do with AdAware. Not much protection there is it?
Prior to the last update, everything got along fine. Not now!
Perhaps we should all be using other malware/spyware prevention software?

Share this post


Link to post
Share on other sites
[quote name='aatex' timestamp='1319559199' post='130104']
I have an ASUS 1005PE Netbook (1.6GHz Intel Atom N450 processor, 2Gb RAM) with a fresh install of Windows 7 w/ SP1 and all updates installed.

I installed Ad-Aware Pro 9.0 and then installed all updates so I now have Ad-Aware Pro 9.5.1.

CPU use regularly goes up to > 50% and RAM use regularly goes up to > 100Mb.  When this happens, an svchost.exe process seems to accompany it, also using ~50% CPU and ~100Mb of RAM.

When this happens, it lasts for several minutes and renders the machine largely useless.

Is this normal?  What is Ad-Aware doing when this happens?

[/quote]
Hi aatex,

Since you have bought the product you can use the Lavasoft support  instead of this forum with volunteers. See this post by LS Digger Barnes for links:http://www.lavasoftsupport.com/index.php?showtopic=30887&view=findpost&p=125583

My guess, it is when Ad-Aware performs a scan or maybe updates. Check your settings regarding scans and updates to see if it is match in time.

Share this post


Link to post
Share on other sites
[quote name='wootlink' timestamp='1319575205' post='130110']
i have a similar problem with my asus gc5290, my cpu spikes to above 50% sometimes to 100% and ram to 75% the cpu temp also rises to about 65°C wile scanning
my computer specs are :[spoiler]Operating System
MS Windows 7 Home Premium 64-bit SP1
CPU
Intel Core i7 920  @ 2.67GHz
Bloomfield 45nm Technology
RAM
9.0GB Triple-Channel DDR3 @ 535MHz (8-8-8-20)
Motherboard
ASUSTeK Computer INC. CG5290 (LGA1366)
Graphics
VOJ320F1A ([email protected])
896MB GeForce GTX 260 (ASUStek Computer Inc)
Hard Drives
117GB INTEL SSDSA2M120G2GC ATA Device (SATA-SSD)
977GB Seagate ST31000528AS ATA Device (SATA)
Optical Drives
HL-DT-ST BDDVDRW GBC-H20L ATA Device
HL-DT-ST DVDRAM GH40N ATA Device
MagicISO Virtual DVD-ROM0000
Audio
SoundMAX Integrated Digital HD Audio[/spoiler]

Edit: seams my sister's laptop does the same thing during a scan.
[/quote]
Hi wootlink,
If you do not want the scan to be fast and use a lot of CPU during the scan, I suggest that you have Ad-Aware open during the scan, since it then will lower the priority and let you do other things during the scan. If you have another antivirus program installed, it is possible that that antivirus program checks every file that Ad-Aware opens, and that behaviour will prolong the scan and increase CPU usage. In that case see if you can change its settings.
1 person likes this

Share this post


Link to post
Share on other sites
[quote name='BRT' timestamp='1319582544' post='130111']
Me too! I have an older Dell Inspiron 2200 running XP. Since loading the latest update of AdAware, the laptop becomes virtually useless at times. When I run Task Manager, I invariably find that the cpu usage has spiked to 100% and STAYS THERE.
The only cure I've found is to use task manager to shut off AAW Service and everything else to do with AdAware. Not much protection there is it?
Prior to the last update, everything got along fine. Not now!
Perhaps we should all be using other malware/spyware prevention software?
[/quote]
Hi BRT,
Do you mean after the update from version 9.5 to 9.5.1 or from version 9.0.x to 9.5?
Changes in 9.5.1: [url="http://www.lavasoftsupport.com/index.php?/topic/31660-951-update/"]http://www.lavasofts...-update/[/url]
Changes in 9.5: [url="http://www.lavasoft.com/mylavasoft/company/blog/new-faster-leaner-version-of-adaware-available"]http://www.lavasoft....are-available[/url]
Do you have another antivirus program installed?

Share this post


Link to post
Share on other sites
@CeciliaB: Thanks for the tip. I'll try contacting support.

FYI, Ad-Aware does not appear to be updating or scanning when it spikes CPU / RAM. It has not run a scan ever (I have not scheduled one).

Share this post


Link to post
Share on other sites
You are welcome, aatex :)
Which process of Ad-Aware is using the CPU during these spikes?
Or do you mean that only svchost is using the CPU during the spikes? If yes: How do you know that it is Ad-Aware that causes the spikes?

Share this post


Link to post
Share on other sites
AAWService.exe is the process using lots of CPU and RAM (it's in the title of this thread). When this happens there is also an instance of svchost that is taking up a lot of CPU and RAM. I don't know for certain they are related, but it seems to happen at the same time.

Share this post


Link to post
Share on other sites
Hi all,

I have also the same problem when I try to do full scan with the latest ver. of AA 9.6. CPU is to high, and my machine goes to sleep, again and again. After several times finaly restart oneself and then I see error "Isdelete program not found - skipping AUTOCHECK"

Ok, I have solutions for this error, but what about full scanning?

Share this post


Link to post
Share on other sites
[quote name='aatex' timestamp='1319778773' post='130218']
AAWService.exe is the process using lots of CPU and RAM (it's in the title of this thread).  When this happens there is also an instance of svchost that is taking up a lot of CPU and RAM.  I don't know for certain they are related, but it seems to happen at the same time.
[/quote]
That is what I thought, but then I got a bit confused when you talked about a CPU load at 50% and svchost taking 50%.
  
To be sure if AAWService and svchost are related, please disable Ad-Aware and see what happens to the CPU load.
How often does this happen?
Ad-Aware Pro updates itself every 6th hour.

Share this post


Link to post
Share on other sites
[quote name='boris79' timestamp='1319786152' post='130219']
Hi all,

I have also the same problem when I try to do full scan with the latest ver. of AA 9.6. CPU is to high, and my machine goes to sleep, again and again. After several times finaly restart oneself and then I see error "Isdelete program not found - skipping AUTOCHECK"

Ok, I have solutions for this error, but what about full scanning?
[/quote]
Hi boris79,
  
If you mean that the computer is turned off, that is usually because it is overheating. See if ventilations holes, fans and heat sinks need to be cleaned. Please, protect your computer from static electricity when you remove dust.
  
You might try to use prime95 to see what happens when the processor is under heavy load: [url="http://www.mersenne.org/freesoft/"]http://www.mersenne.org/freesoft/[/url]

If the computer isn't turned off due to overheating when the CPU is heavily loaded, please check the power settings: [url="http://windows.microsoft.com/en-US/windows-vista/Power-plans-frequently-asked-questions"]http://windows.micro...asked-questions[/url] That is for Vista but there are similar settings in other Windows versions.

Share this post


Link to post
Share on other sites
[quote name='CeciliaB' timestamp='1319804279' post='130224']
Hi boris79,

If you mean that the computer is turned off, that is usually because it is overheating. See if ventilations holes, fans and heat sinks need to be cleaned. Please, protect your computer from static electricity when you remove dust.

You might try to use prime95 to see what happens when the processor is under heavy load: [url="http://www.mersenne.org/freesoft/"]http://www.mersenne.org/freesoft/[/url]

If the computer isn't turned off due to overheating when the CPU is heavily loaded, please check the power settings: [url="http://windows.microsoft.com/en-US/windows-vista/Power-plans-frequently-asked-questions"]http://windows.micro...asked-questions[/url] That is for Vista but there are similar settings in other Windows versions.
[/quote]
Thanks for the quick reply CeciliaB,

Yes I understand that my computer goes to overheating, but the reason of this is full scanning with AA9.6. I do lenovo "stress test" on my computer and during this, the computer still working. Also when NOD32 do deep full scanning, also everything is ok.

Even I put AA9.6 in the background, I have sam results. Overheating and restart or turn off the machine.

Windows 7pro SP1
Intel Core 2CPU T7200 2.00GHz
4MB Ram

Share this post


Link to post
Share on other sites
Finally AA finish full scanning with "only one" overheating and entering into to the sleep mode. Scanning is finished after 7-8 hours! (about 60GB used space on HDD).

Share this post


Link to post
Share on other sites
You are welcome, boris79 :)

Does Nod32 control every file that is opened?
Many antivirus programs investigates every opened file and if Nod32 is doing that it means that every file that Ad-Aware opens Nod32 will open too. That will certainly load the processor and hard disk even more, which will give high temperatures and long scan time.

Share this post


Link to post
Share on other sites
[quote name='CeciliaB' timestamp='1320066319' post='130270']
You are welcome, boris79 :)

Does Nod32 control every file that is opened?
Many antivirus programs investigates every opened file and if Nod32 is doing that it means that every file that Ad-Aware opens Nod32 will open too. That will certainly load the processor and hard disk even more, which will give high temperatures and long scan time.
[/quote]
I must check this options in my NOD32 Antivirus 5.0.94.0...with AA smart scann I have no any problem.

Share this post


Link to post
Share on other sites
Wow, I indicated that I had this problem back in August with version 9.5 and it still has not been resolved. I replaced Adaware with other equally effective products back then.

Share this post


Link to post
Share on other sites
Let us hope it will be different and better in the next major version of Ad-Aware that Lavasoft is working with.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0