synchtw

Curse Application Being Blocked

Recommended Posts

Hi-

 

I am finding that your software is blocking the Curse application (https://www.curse.com/) from loading. When I disable adaware antivirus, it loads just fine. If adaware antivirus is enabled, however, the loading screen cycles indefinitely.

 

Please let me know if more information is needed.

 

Thanks.

Share this post


Link to post
Share on other sites

Hi synchtw,

Thanks for your report. I haven’t been able to recreate the problem. When I visit curse.com it invites me to download the Twitch Desktop app, which, when I install, installs without any problems or alerts from Ad-Aware.

Can you describe the steps I need to take to recreate the problem?

Thanks,

Andy
Lavasoft Malware Lab

Share this post


Link to post
Share on other sites

I am having the same issue. The problem was stated in the first post. It has nothing to do with the website being blocked. The problem is when you go to start the Curse Forge application, the loading screen gets stuck in an infinite loop until the adaware software is turned off. Once the Adaware software is turned off, then the curse application loads almost immediately after. I don't like that I have to turn off a form of protection from virus and malware just to be able to play a certain game on my PC. If you need any more information regarding how to recreate this I will try to let you know anything else that I can.

Share this post


Link to post
Share on other sites

Hi,

In order to recreate the problem, I need to first install the application that Ad-Aware is interfering with.

Can you provide an exact link where I can download the application, or upload the installer here please?

Thanks,

Andy

Lavasoft Malware Lab

Share this post


Link to post
Share on other sites

Hi,

 

I am also experiencing the problem above. The app in question is the newly re-named Twitch Desktop App (as Curse and Twitch have now merged), and can be found on here, with a direct link to the app here.

 

To be clear, neither this version, nor the previous version under the name Curse Launcher will successfully launch if Ad Aware is running. I had not yet updated to the Twitch App before starting this post, but I have now done so and can verify that the problem still exists.

Edited by rickvoid

Share this post


Link to post
Share on other sites

Hi rickvoid,

 

Thanks for the additional information. If I've understood correctly, Ad-Aware isn't alerting that it has blocked files, rather, Ad-Aware appears to be conflicting with the Twitch app and stopping it from running:

 

01 Error.png

 

.. and when you kill Ad-Aware, Twitch runs:

 

03 Twitch success.png

 

I was able to recreate this and I've notified the development team about this for investigation. Thanks for letting us know.

 

Regards,

 

Andy

Lavasoft Malware Lab

Share this post


Link to post
Share on other sites

Is this still being worked on? And if so, do we have an eta on when it will be finished? I am trying to use the now Twitch launcher, but always run into the same start cycle. Is there any way to temporarily fix it in the mean time?

Share this post


Link to post
Share on other sites

Hi LousyLynx,

I'm sorry but I haven't yet been able to find a person that can answer you due to vacations.

Share this post


Link to post
Share on other sites

Hi again,

Sorry, no ETA.

Please, stop the adaware service, rename the file C:\Program Files\adaware\adaware antivirus\AdAwareProxyEngine\1.0.0.8\httproxy.dll to something else (e.g. httproxy.dll.notused) and then start the adaware service before testing and informing us if you still have the same problem.

If you need more detailed instructions, please ask.

Share this post


Link to post
Share on other sites
3 hours ago, CeciliaB said:

Hi again,

Sorry, no ETA.

Please, stop the adaware service, rename the file C:\Program Files\adaware\adaware antivirus\AdAwareProxyEngine\1.0.0.8\httproxy.dll to something else (e.g. httproxy.dll.notused) and then start the adaware service before testing and informing us if you still have the same problem.

If you need more detailed instructions, please ask.

Thank you so much! This worked! Hoping for a fix in the virus definitions, though. I am sure that file blocked some sort of virus(es)

Share this post


Link to post
Share on other sites

You're welcome :)

If you've a paid version of adaware antivirus, that fix would disable its Web Protection, but if you've the free version the protection isn't affected.

Share this post


Link to post
Share on other sites

I am having the same issue and I have a paid subscription.  I see that this is not a new issue but that it also have not been resolved.  I see that you did find a fix for the free users but I paid for the web protection to be a part of my service.  Please help me with this issue as soon as possible.

Share this post


Link to post
Share on other sites

Hi Restassured316,

I've asked my contact person at adaware software what has happened during the last year, but I didn't receive an answer before the weekend, I'll ask on Monday again.

Share this post


Link to post
Share on other sites
On 11/1/2018 at 8:57 PM, Restassured316 said:

I am having the same issue and I have a paid subscription.  I see that this is not a new issue but that it also have not been resolved.  I see that you did find a fix for the free users but I paid for the web protection to be a part of my service.  Please help me with this issue as soon as possible.

Hi again @Restassured316,

It seems that the posted solution is still the only one, but since you've a paid version you can contact the support team from the menus within adaware antivirus.

Share this post


Link to post
Share on other sites

According to my contact person the problem will be solved in the next major version that will be released during 2019 (the plan says Q1 but that can be changed).

Share this post


Link to post
Share on other sites

So I am paying for a hassle.  That is fantastic news.  I appreciate it very much, please let your contact know that it is issues like this that are causing your paying members to leave and go else where.  I love the program but I do a lot on Twitch and unfortunately not being able to use it while my computer is protected is frustrating due to the fact that is why I payed for the web protection. so pissed off with this issue. 

  • Sad 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now